Analog Devices® Eagle® driver for *BSD

Beastie

Tutorial list

1. Automatic connection at startup

This suggestion originally posted by QuiRK on the forum allows automatic connection at startup under FreeBSD.
Firstly, edit the file /boot/loader.conf and add the line:

ueagle_load="YES"

This line will tell the system to load the ueagle module at startup. Now you must check that the USB daemon is running (usbd). Check in the file /etc/rc.conf that you have the line:

usbd_enable="YES"

The next step consists in telling the USB daemon to flash the firmware each time a pre-firmware modem is connected to the USB. Add the following lines to the /etc/usbd.conf file:

device "Analog Devices Eagle chipset, firmware download"
    devname "ugen[0-9]+"
    vendor  0x1110 (1)
    product 0x9010 (2)
    attach  "/usr/local/sbin/eagleflash -f /dev/${DEVNAME}"
(1)
Change this to match the vendor Id of your modem (eagle=0x1110, usr=0x0baf).
(2)
Change this to match the product Id of your modem. You can get this value using the "usbdevs -v" command when your modem is connected to the USB and before flashing its firmware. Most common values include 0x9010 (EagleI), 0x9022 (EagleII) and 0x9024 (EagleIIC).

Last step consists in telling the USB daemon to synchronize the modem and to establish the connection with your provider. This step depends on the way you are connecting to your provider (either with PPPoA or IPoA):

1) PPPoA

Add the following lines in your /etc/usbd.conf file:

device "Analog Devices Eagle chipset"
  devname "ueagle[0-9]+"
  attach  "/usr/local/sbin/eagle_pppoa ${DEVNAME} start label(1)"
  detach  "/usr/local/sbin/eagle_pppoa ${DEVNAME} stop"
(1)
The section in your /etc/ppp/ppp.conf file (typically called adsl).

2) IPoA (Free dégroupé)

Add the following lines in your /etc/usbd.conf file:

device "Analog Devices Eagle chipset"
  devname "ueagle[0-9]+"
  attach  "/usr/local/sbin/eagle_ipoa ${DEVNAME} start vpi(1) vci(2) ip(3) gw(4)"
  detach  "/usr/local/sbin/eagle_ipoa ${DEVNAME} stop"
(1)
The VPI value provided by your ISP.
(2)
The VCI value provided by your ISP.
(3)
Your static IP address.
(4)
The IP address of your gateway.

You can then reboot your machine and everything should work automatically!

2. Sharing your Internet connection with ppp

Firstly, IP forwarding must be enabled on the machine your modem is connected to. Check that the following directive is present in your /etc/rc.conf file:

gateway_enable="YES"

User ppp has some built-in NAT capabilities. It is sufficient in most cases but if you need additionnal features, you should consider using natd or ipnat. Configuration of natd or ipnat is beyond the scope of this document though.

To enable the built-in network address translation (NAT) on your ppp connection, add the following two lines in your /etc/ppp/ppp.conf configuration file:

adsl:
 ...
 nat enable yes
 nat same_ports yes

You should now reboot your machine for IP forwarding to be enabled. Others machines on your network should then be able to access the Internet through your gateway. It is also strongly advised to configure a firewall using either the built-in filter rules of ppp or preferably ipfw.


Copyright © 2003, 2004 Damien Bergamini. All rights reserved.
Contact me for more informations on this site.

valid XHTML1.1 valid CSS